Чат Telegram
Группа ВКонтакте
php

Выдаёт ошибку

Урок 23
файл auth.php
на 16 строке Google Chrome ругается на ?string
Что нужно сделать?

alexander_shloma@mail.ru 13.07.2020 в 22:09

Ответы на вопрос (1)


Нужна версия PHP не ниже 7.1

ivashkevich 14.07.2020 в 06:38

У меня оказалось PHP Version 7.0.33
Как можно установить PHP Version 7.1
Я пользуюсь рекомендованным Вами OpenServer

alexander_shloma@mail.ru 14.07.2020 в 12:39

Скачайте последнюю версию с их официального сайта и поменяйте версию в настройках.

ivashkevich 14.07.2020 в 13:58

Теперь работает. Спасибо!

alexander_shloma@mail.ru 14.07.2020 в 20:07

Можете объяснить что это такое "?string" ?

mavzurhon@gmail.com 21.07.2020 в 20:02

Это значит что функция может вернуть либо строку, либо null.

ivashkevich 22.07.2020 в 07:13

Добавить новый ответ